Policy Based Routing (PBR)

While dynamic routing protocols provide easy deployment, there will be situations in which more specific selection of routing paths can be advantageous. Cisco Policy Based Routing provides a flexible mechanism for network administrators to customize the operation of the routing table and the flow of traffic within their networks.

Cisco Policy Based Routing offers many advanced features, including selection and forwarding of traffic to discreet Virtual Routing and Forwarding (VRF) instances, as well as Enhanced Tracking of the availability of next-hops.

Equal Access Example

The following example provides two sources with equal access to two different service providers. Packets arriving on asynchronous interface 1 from the source 209.165.200.225 are sent to the router at 209.165.200.228 if the router has no explicit route for the destination of the packet. Packets arriving from the source 209.165.200.226 are sent to the router at 209.165.200.229 if the router has no explicit route for the destination of the packet. All other packets for which the router has no explicit route to the destination are discarded.

access-list 1 permit 209.165.200.225

access-list 2 permit 209.165.200.226

!

interface async 1

ip policy route-map equal-access

!

route-map equal-access permit 10

match ip address 1

set ip default next-hop 209.165.200.228

route-map equal-access permit 20

match ip address 2

set ip default next-hop 209.165.200.229

route-map equal-access permit 30

set default interface null0

Differing Next Hops Example

The following example illustrates how to route traffic from different sources to different places (next hops), and how to set the Precedence bit in the IP header. Packets arriving from source 209.165.200.225 are sent to the next hop at 209.165.200.227 with the Precedence bit set to priority; packets arriving from source 209.165.200.226 are sent to the next hop at 209.165.200.228 with the Precedence bit set to critical.

access-list 1 permit 209.165.200.225

access-list 2 permit 209.165.200.226

!

interface ethernet 1

ip policy route-map Texas

!

route-map Texas permit 10

match ip address 1

set ip precedence priority

set ip next-hop 209.165.200.227

!

route-map Texas permit 20

match ip address 2

set ip precedence critical

set ip next-hop 209.165.200.228

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s